2017 RT29 inverter failure?

Have a tech question or tidbit you wish to share with the other Ranger Tug owners? Post it here.

2017 RT29 inverter failure?

Postby 1Mainer50 on Wed Jul 17, 2019 11:09 am

My battery banks were empty after the ignition switch was inadvertently left on for several days while plugged into shore power. My mechanic did an electrical check and found the inverter was outputting 5 amps instead of the 50 the spec sheet said to expect. It's an Abso IC122055 inverter. He thinks that an internal switch cut back the power as the inverter overheated, and may be broken. Last fall the boat briefly wouldn't charge while on shore power but the problem resolved itself (ha!).
Any thoughts on this? Hate in invest in a new inverter if I don't have to.
1Mainer50
 
Posts: 13
Joined: Thu Jul 20, 2017 9:27 am
City: Kennebunkport
State/Province: ME
Ranger/Cutwater Model: R-29 S
Vessel Name: Saoirse

Re: 2017 RT29 inverter failure?

Postby Matty on Wed Jul 17, 2019 1:00 pm

I would call help desk at manufacturer of inverter to confirm. Seems odd your situation would cause a failure.
Matty
 
Posts: 206
Joined: Tue Feb 20, 2018 11:58 am
City: New Smyrna Beach
State/Province: FL
Ranger/Cutwater Model: R-27
Vessel Name: IN THE FALL (2018)

Re: 2017 RT29 inverter failure?

Postby Scuba Too on Wed Jul 17, 2019 1:09 pm

I don't know if it's related but my battery power went too low on a long weekend and wouldn't charge. Per the manual "If the house bank drops below 10.8v you must reset the charging relay by switching on the parallel while the engine is running." It fixed my problem but the inverter was only indirectly affected by the low power.
Scuba Too
 
Posts: 163
Joined: Mon Jul 25, 2016 12:39 pm
City: Trabuco Canyon
State/Province: CA
Ranger/Cutwater Model: R-29 Classic
Vessel Name: Blue Honu
MMSI Number: 367783950

Re: 2017 RT29 inverter failure?

Postby BB marine on Wed Jul 17, 2019 3:26 pm

1Mainer50 wrote: It's an Abso IC122055 inverter. He thinks that an internal switch cut back the power as the inverter overheated, and may be broken.


I believe the Kisae has 4 manual output settings 5,15,35,55 amps did it possibly get programed for max output of 5 amps? I believe that many inverter/chargers have derating values if the compartment is too high or the internal temperature of the inverter is to high limiting output. I would try resetting the inverter to factory default settings and confirm it is not operating hot or in a warm compartment then retest output.
Brian Brown
Cutwater 26
PORT-A-GEE
portageelooper.blogspot.com
bkb_marine@msn.com
BB marine
 
Posts: 999
Joined: Mon Feb 01, 2016 10:30 pm
City: Lemont
State/Province: IL
Non-Ranger Model: 26 Cutwater
Vessel Name: PORT-A-GEE


Return to General Technical Discussion

Who is online

Users browsing this forum: No registered users and 2 guests